Jut Flight - Airshow Pilot

FAQs

An Error Appears, Referring To Microsoft.Flightsimulator.Simconnect, Version 10.0.61259.0
Please install .NET framework 2.0, followed by .NET framework 3.5: Download .NET framework 2.0 Download .NET framework 3.5 If you still recieve the...
Sat, 24 Mar, 2018 at 5:31 PM