Latest Update: 16/10/2013


The below log shows all updates for this product since release:


Service Pack 5

New features 

- Quick Drive updated with moving A.I. A new concept..!

- A.I. will appear at random and based on your Consist collection, next time you play the QD you'll get different consists!

- Repeater bracket signals fixed (Where applicable)

- Track smoothness improved Dundee Station, Dundee Central junction and Taybridge ramp

- All Level Crossings fixed with stopping traffic where applicable.

- All JT - Default scenarios updated with in Cab start.

- For new and future scenarios. Signal and destination points fixed and improved.

- At Camperdown. (East of Dundee), At Dundee central junction sidings and Dock St Tunnel, At Wormit (Taybridge)

- Misc Improved scenery and occlusions.


Please note - the Voyager scenarios can only be run if you have purchased the Voyager or the Voyager Advanced from Just Trains. The two included Voyager scenarios will work with the 221 version of both the Voyager and Voyager Advanced products. 


Please note - after installing the service pack third party scenarios may not work, these may show broken consist errors.  


Installation: 


Download the update using the link below, double click on the installer and follow the on screen instructions.Users of the DVD version will need the disc in the drive when running the update. 


Users of the download version will need to activate the update using their Just Trains account username and password.


122MB